您的位置:首页 > 汽车 > 时评 > 数据结构:模拟队列

数据结构:模拟队列

2025/1/8 6:19:34 来源:https://blog.csdn.net/weixin_43790371/article/details/139321176  浏览:    关键词:数据结构:模拟队列

数据结构:模拟队列

    • 题目描述
    • 参考代码

题目描述

在这里插入图片描述
输入样例

10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6

输出样例

NO
6
YES
4

参考代码

#include <iostream>using namespace std;const int N = 100010;int q[N], hh, tt;int m, x;
string op;void init()
{hh = 0;tt = -1;
}void push(int x)
{q[++tt] = x;
}void pop()
{hh++;
}string empty()
{return tt < hh ? "Yes" : "No";
}int query()
{return q[hh];
}int main()
{init();cin >> m;while (m--){cin >> op;if (op == "push"){cin >> x;push(x);}else if (op == "pop"){pop();}else if (op == "empty"){cout << empty() << endl;}else{cout << query() << endl;}}return 0;
}

版权声明:

本网仅为发布的内容提供存储空间,不对发表、转载的内容提供任何形式的保证。凡本网注明“来源:XXX网络”的作品,均转载自其它媒体,著作权归作者所有,商业转载请联系作者获得授权,非商业转载请注明出处。

我们尊重并感谢每一位作者,均已注明文章来源和作者。如因作品内容、版权或其它问题,请及时与我们联系,联系邮箱:809451989@qq.com,投稿邮箱:809451989@qq.com