您的位置:首页 > 房产 > 建筑 > 鹤壁市城乡一体化示范区范围_整站优化外包公司_搜索引擎优化seo课程总结_网络营销推广策划方案

鹤壁市城乡一体化示范区范围_整站优化外包公司_搜索引擎优化seo课程总结_网络营销推广策划方案

2025/3/10 11:38:22 来源:https://blog.csdn.net/flyidj/article/details/143438448  浏览:    关键词:鹤壁市城乡一体化示范区范围_整站优化外包公司_搜索引擎优化seo课程总结_网络营销推广策划方案
鹤壁市城乡一体化示范区范围_整站优化外包公司_搜索引擎优化seo课程总结_网络营销推广策划方案

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 solution:
 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'
vector<int>p[105];
vector<int>leaf(105);
int n,m;
int maxheight=0;
int main()
{cin>>n>>m;for(int i=0;i<m;i++){int node,k;cin>>node>>k;for(int j=0;j<k;j++){int t;cin>>t;p[node].push_back(t);}}function<void(int,int)>dfs=[&](int node,int h)->void{if(!p[node].size()){maxheight=max(maxheight,h);leaf[h]++;}else{for(auto it:p[node]){dfs(it,h+1);}}};dfs(1,1);for(int i=1;i<=maxheight;i++){if(i!=1)cout<<' ';cout<<leaf[i];}
}

版权声明:

本网仅为发布的内容提供存储空间,不对发表、转载的内容提供任何形式的保证。凡本网注明“来源:XXX网络”的作品,均转载自其它媒体,著作权归作者所有,商业转载请联系作者获得授权,非商业转载请注明出处。

我们尊重并感谢每一位作者,均已注明文章来源和作者。如因作品内容、版权或其它问题,请及时与我们联系,联系邮箱:809451989@qq.com,投稿邮箱:809451989@qq.com