您的位置:首页 > 汽车 > 时评 > 网页设计二级页面_搜狗整站优化_全网自媒体平台大全_谷歌搜索为什么用不了

网页设计二级页面_搜狗整站优化_全网自媒体平台大全_谷歌搜索为什么用不了

2024/9/22 14:54:15 来源:https://blog.csdn.net/2301_80882026/article/details/142349963  浏览:    关键词:网页设计二级页面_搜狗整站优化_全网自媒体平台大全_谷歌搜索为什么用不了
网页设计二级页面_搜狗整站优化_全网自媒体平台大全_谷歌搜索为什么用不了

pSort

题面翻译

题目描述

给定一个长度为 n n n 的数列 { a n } \{a_n\} {an},初始时 { a n } = { 1 , 2 , … , n } \{a_n\} = \{1, 2, \dots, n\} {an}={1,2,,n}。位置 i i i 上的数可以和位置 i ± d i i \pm d_i i±di 上的数交换。给定一个 1 ∼ n 1 \sim n 1n 的全排列,问初始的数列可否交换成给定的形式。

输入格式

第一行一个整数 n n n

第二行 n n n 个互不相同的整数表示目标数列。

第三行 n n n 个整数表示 d 1 , d 2 , … , d n d_1, d_2, \dots, d_n d1,d2,,dn

输出格式

如果能交换到给定样式,输出 YES,否则输出 NO

数据范围

1 ≤ n ≤ 100 1 \le n \le 100 1n100

题目描述

One day $ n $ cells of some array decided to play the following game. Initially each cell contains a number which is equal to it’s ordinal number (starting from $ 1 $ ). Also each cell determined it’s favourite number. On it’s move $ i $ -th cell can exchange it’s value with the value of some other $ j $ -th cell, if $ |i-j|=d_{i} $ , where $ d_{i} $ is a favourite number of $ i $ -th cell. Cells make moves in any order, the number of moves is unlimited.

The favourite number of each cell will be given to you. You will also be given a permutation of numbers from $ 1 $ to $ n $ . You are to determine whether the game could move to this state.

输入格式

The first line contains positive integer $ n $ ( $ 1<=n<=100 $ ) — the number of cells in the array. The second line contains $ n $ distinct integers from $ 1 $ to $ n $ — permutation. The last line contains $ n $ integers from $ 1 $ to $ n $ — favourite numbers of the cells.

输出格式

If the given state is reachable in the described game, output YES, otherwise NO.

样例 #1

样例输入 #1

5
5 4 3 2 1
1 1 1 1 1

样例输出 #1

YES

样例 #2

样例输入 #2

7
4 3 5 1 2 7 6
4 6 6 1 6 6 1

样例输出 #2

NO

样例 #3

样例输入 #3

7
4 2 5 1 3 7 6
4 6 6 1 6 6 1

样例输出 #3

YES

思路:对于每一个数,想要到达它原来的位置的话,我们应该能够确保它们在一个连通块内,只有这样才能够到达目标位置,因此我们可以想到利用并查集,最后判断i与fa[a[i]]是否一样即可

AC代码:

#include<bits/stdc++.h>using namespace std;typedef long long ll;
typedef pair<int, int>PII;
const int MOD = 998244353;
const int N = 4e5 + 10;int dx[] = {0, 0, 1, -1};
int dy[] = {1, -1, 0, 0};int fa[110];
int a[110];
int d[110];
int finds(int x)
{if(x != fa[x]) fa[x] = finds(fa[x]);return fa[x];
}void un(int x, int y)
{int o1 = finds(x), o2 = finds(y);if(o2 != o1) {fa[o2] = fa[o1];}
}
int main()
{int n;cin >> n;for(int i = 1; i <= n; i ++) fa[i] = i;for(int i = 1; i <= n; i ++) cin >> a[i];for(int i = 1; i <= n; i ++) cin >> d[i];for(int i = 1; i <= n; i ++){if(i > d[i]) un(i, i - d[i]);if(i + d[i] <= n) un(i, i + d[i]);}int f = 0;for(int i = 1; i <= n; i ++){if(finds(i) != finds(a[i])){f = 1;break;}}if(f) puts("NO");else puts("YES");
}

版权声明:

本网仅为发布的内容提供存储空间,不对发表、转载的内容提供任何形式的保证。凡本网注明“来源:XXX网络”的作品,均转载自其它媒体,著作权归作者所有,商业转载请联系作者获得授权,非商业转载请注明出处。

我们尊重并感谢每一位作者,均已注明文章来源和作者。如因作品内容、版权或其它问题,请及时与我们联系,联系邮箱:809451989@qq.com,投稿邮箱:809451989@qq.com