您的位置:首页 > 健康 > 美食 > 网站建设效果有客优秀网站建设效果_猎头公司一般怎么收费的_衡阳seo优化_网站建设加推广优化

网站建设效果有客优秀网站建设效果_猎头公司一般怎么收费的_衡阳seo优化_网站建设加推广优化

2024/10/6 8:37:18 来源:https://blog.csdn.net/flyidj/article/details/142531486  浏览:    关键词:网站建设效果有客优秀网站建设效果_猎头公司一般怎么收费的_衡阳seo优化_网站建设加推广优化
网站建设效果有客优秀网站建设效果_猎头公司一般怎么收费的_衡阳seo优化_网站建设加推广优化

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

 solution:
 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define endl '\n'int n;const int maxn=1e2+5;
vector<int>tmp(maxn);
vector<int>a,b;
bool flag=false;
void insertsort(vector<int>&a)
{int n=a.size();int i,j,temp;for(i=1;i<n;i++){if(a[i]<a[i-1]){temp=a[i];for(j=i-1;j>=0 && a[j]>temp;j--){a[j+1]=a[j];}a[j+1]=temp;}if(!flag && a==b){flag=true;continue;}if(flag)break;}
}
void mergesort(vector<int>&a,int l,int r)
{if(l>=r)return;int mid=l+r>>1;mergesort(a,l,mid);mergesort(a,mid+1,r);int k=0;int i=l,j=mid+1;while(i<=mid && j<=r){if(a[i]<=a[j])tmp[k++]=a[i++];else tmp[k++]=a[j++];}while(i<=mid)tmp[k++]=a[i++];while(j<=r)tmp[k++]=a[j++];for(i=l,j=0;i<=r;i++,j++){a[i]=tmp[j];}
}
void Mergesort(vector<int>&a)
{int n=a.size();for(int k=2;k/2<=n;k*=2){for(int i=0;i<n;i+=k){mergesort(a,i,min(i+k,n)-1);}if(a==b && !flag){flag=true;continue;}if(flag)return;}
}
int main()
{cin>>n;for(int i=0;i<n;i++){int t;cin>>t;a.push_back(t);}for(int i=0;i<n;i++){int t;cin>>t;b.push_back(t);}vector<int>t(a);insertsort(a);if(flag){cout<<"Insertion Sort"<<endl;for(int i=0;i<a.size();i++){if(i)cout<<' ';cout<<a[i];}}else{cout<<"Merge Sort"<<endl;a=t;Mergesort(a);if(flag)for(int i=0;i<a.size();i++){if(i)cout<<' ';cout<<a[i];}}
}

版权声明:

本网仅为发布的内容提供存储空间,不对发表、转载的内容提供任何形式的保证。凡本网注明“来源:XXX网络”的作品,均转载自其它媒体,著作权归作者所有,商业转载请联系作者获得授权,非商业转载请注明出处。

我们尊重并感谢每一位作者,均已注明文章来源和作者。如因作品内容、版权或其它问题,请及时与我们联系,联系邮箱:809451989@qq.com,投稿邮箱:809451989@qq.com